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1. Installation 

Installation documentation covers installation of BI server on-premises. 

1.1. Prerequisite 

 Information about RDP connection and Azure Analysis Services 

RDP and D365 F&O credentials must be provided ahead of time, Azure Analysis Services are a result of 

infrastructure installation (fields here are for example only): 

 

Azure Analysis Services (optional): 

Description Value 

Azure Analysis Services asazure://westeurope.asazure.windows.net/bi4dynamicshybrid 

Username (AAS admin) mg@bi4dynamics.com 

Password Qpewoicsj490wkss 

 

RDP credentials: 

Description Value 

RDP Public IP (or RDP file) 51.132.66.72 

Admin Account admin-user 

Admin Account Password 6!dJ2yS34MbbQiPHs@rd 

 D365 F&O credentials 

Description Value 

D365 F&O Admin User adminuser@bi4dynamics.onmicrosoft.com 

D365 F&O Admin User Password rtPxXqxJ2lkOIJFR9Eki#8 

  

mailto:mg@bi4dynamics.com
mailto:adminuser@bi4dynamics.onmicrosoft.com
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1.2. Installing BI4Dynamics application 

IMPORTANT! Before installing BI4Dynamics, please check hardware and software requirements, make 

sure you have sufficient permissions and an active internet connected. 

IMPORTANT! The installation process must be started on a server where BI4Dynamics Data Warehouse 

will be created. 

1. Double-click BI4Dynamics.exe to start the installation*.  

*Always start BI4Dynamics as an administrator. 

Note: The name of the file varies based on the version you are using. 

2. Follow the instructions on screen and accept the license agreement. 

 

3. Choose Default or Express option 

 

 

 

 

 

 

 

 

4. The installer will check for some of the 

prerequisites. If any of the tests will fail you can 

click on the result to see the error. You must fix the 

problem before repeating the test. Once all the 

tests are successfully completed you can continue 

with the installation. 

 

5. If a correct version of Shared Management Objects, 

Analysis Management Objects or .NET Framework 

is not installed, please click the Install button, 

which will trigger the installation of correct version 

of SMO’s, AMO’s, CLR Types or .NET Framework. 
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6. Select the folder where you would like to install 

BI4Dynamics. You can choose to create a shortcut 

on the desktop and/or in the start menu. Click 

Next. 

 

 

7. Confirm the configuration and begin the 

installation of BI4Dynamics. 

 

 

 

8. Click Finish after the installation is completed. 
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1.3. Creating BI4Dynamics instance 

Deploying a BI4Dynamics solution is a seven-step process: 

1. Providing license information 

2. Creating an instance 

3. Adding the data sources 

4. Selecting global dimensions 

5. Selecting companies 

6. Selecting Framework module 

7. Completing installation 

When you open the application, an instance wizard will start to guide you through the configuration. 

 Step 1: Providing license information 

1) Launch BI4Dynamics.exe from the folder where BI4Dynamics was installed to open the 

application. 

 
Note: BI4Dynamics is 64-bit application, but the default installation location is C:\Program Files (x86)\BI4Dynamics 

AX. Application can also be started from the Desktop shortcut or from the Start Menu shortcut. 

2) Enter the BI4Dynamics online license key   

OR 

3) Follow the instructions on screen to receive an offline license key (in case you do not have the 

internet connection or port 80 on the server is closed). 

 
Note: If you experience any problems with authorization, please contact us via support@bi4dynamic.com.  

4) Click Next. 

  

mailto:support@bi4dynamic.com
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 Step 2A: Creating a new instance with local Analysis Services 

Instance properties 

1. Type the Name of the new instance. 

2. Select what Language the solution will be deployed in.  

SQL server 

3. Keep or change Database Name of the BI4Dynamics Data Warehouse.  

4. Type SQL server name (Use local server name). 

5. Select or Type in the SQL Server Instance name where the BI4Dynamics Data Warehouse will be 

deployed. 

 

6. Authentication type: Windows 

Analysis Services 

1. Keep or change the Analysis Database Name of the Analysis Services instance. 

2. Keep or change the Analysis Database Server name where the Analysis Services model will be 

deployed. 

3. Authentication type: Windows. 

If you plan to use Azure Analysis Services, follow Chapter 2 to install Azure Analysis Services 

and On-Premises gateway. Come back when finished. 
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 Step 2B: Creating a new instance with Azure Analysis Services 

This step is different in Azure Analysis Services installation compared to local Analysis Services. 

 

This is the beginning of specificity step in Azure Analysis Services installation.  

Instance properties 

1. Type the Name of the new instance. 

2. Select what Language the solution will be deployed in.  

SQL server 

3. Keep or change Database Name of the BI4Dynamics Data Warehouse.  

4. Type SQL server name (Use local server name). 

5. Select or Type in the SQL Server Instance name where the BI4Dynamics Data Warehouse will be 

deployed. 

Azure Analysis Services 

• SQL Analysis Server name: enter the name of the Azure Analysis Services (see in Chapter 2) 

• Authentication: Azure Active Directory 

• Username: email of the admin user (adminuser@domain.com) that has been entered when creating 

Azure Analysis Services 

• Password: enter password for Azure Active Directory  

 

 

This is the end of specificity step in Azure Analysis Services installation. 

 

Integration Services 

Check SQL Integration Service to process BI4Dynamics using the Integration services (parallel 

processing). 

 

Refresh 

Click Refresh to set default values for SQL Database file Locations (data and log files) and SQL 

Database Collation are entered automatically. Modify if necessary. 

 

This is how setting should look (showing Azure Analysis Services option): 

mailto:adminuser@domain.com
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Click Next. 
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 Step 3: Add Data Source – D365 F&O Cloud Source 

This information is about adding Data Source(s) for BI4Dynamics instance. 

If information about Dynamics 365 AX connector is not available at the time of installation, go to chapter 

Implementation option - DFO/AX connector not available and complete steps prescribed there 

instead.  

 

1) Set Data Source Version. For D365 F&O that would be D365 On-Premises 

2) In the field SQL Server Instance select the server that is hosting the source. 

3) Select Database from the pop-up menu of Database Name. 

4) Select Windows Authentication as a method of Authentication. 

5) Test connection by clicking Test connection to SQL Database. 

 

 Step 3b: Setup Dynamics 365 AX Connector 

• Service hostname URL - link to Microsoft Dynamics Finance and Operations 

(abccorp.operations.dynamics.com). 

• Tenant ID – same as Blob Tenant ID. 

• Client app id 

Open Azure portal and search for App registrations. 
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Select BI4Dynamics app. 

 
 

Copy Application (client) ID value. 

 

• Client secret key 

Select Certificates & secrets from the menu on the left. Create a new client secret and save value, since 

it will not be possible to get it later. 

 

• Username & Password to Microsoft Dynamics. 

• Test connection by clicking Test connection to AX Services. Following window should appear: 

 

Click Add Data Source to add the selected data source and wait…  

Your screen should look like this:  
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You have successfully added data source 

Click Next.  

 Step 4: Selecting Global Dimensions 

Add global financial dimensions from your D365 F&O. 

 

 Step 5: Selecting Companies 

1. From the list of companies tick the ones you want to include in your instance and configure 

additional settings for each selected company:  

a. Local Currency: local currency code (e.g. GBP) – get data from D365 F&O. 

b. Additional Currency: select the additional currency code for this company (e.g. USD). 

c. Select Language ID from the pop-up menu. 

d. Add financial dimension and relate them with global financial dimensions. 

 

2. Click Next. 
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 Step 6: Selecting Modules 

Select Framework module.  

 
Click Next. 

 Step 7: Completing installation 

Check Deploy 

Uncheck Process and Automatic update and, click Next. 

 
Wait for solution to be deployed 
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1.4. Installing Data Warehouse and Analytics 

Move to Install tab and click Installation button. 

 
 

Click Run - while this is running, you can go and check execution on Log tab: 

 
and wait for the “Installation Completed” message. 

 
 

 

 

 

 

You have successfully installed and processed data warehouse and analytics. 
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2. Implementation options 

2.1. Installing On-premises Data Gateway 

When you choose to install analytics as Azure Analysis Services, you need to install following: 

- Azure Analysis Service in Azure portal 

- On-Premises Gateway on your BI server 

We recommend to first install On-premises Gateway and later Azure Analysis Services as we enter 

parameters from on-Premises gateway to Azure Analysis Service settings. 

 Install On-Premises data gateway on the server 

Download On-Premises data gateway to server 

Download On-Premises Data gateway from Microsoft site: 

https://www.microsoft.com/en-us/download/details.aspx?id=53127 

 

Install On-premises data gateway 

Follow the documentation from Microsoft site: 

https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-install 

 

Note: Please be very careful when selecting the right region.  Installation process will set On-Premises 

Gateway to your default region that may not be the same as Azure Analysis Services. The feature is not 

so exposed during installation so it can easily go unnoticed. 

 

 

If you have set the wrong Region, and your Gateway does not appear in the available list of gateways of 

your Azure Analysis Services than you must re-install On-Premises data gateway. 

 Setup On-premises Data Gateway as Azure Service 

Go to Azure portal  

Click on icon On-premises Data Gateway 

https://www.microsoft.com/en-us/download/details.aspx?id=53127
https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-install
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Click on + New 

 

Enter all fields: 

Resource name 

Subscription 

Resource group 

Location 

Installation name: select on-premises gateway that you have 

created in previous step from the list of available gateways 

 

Then click Create 

 

Click Go to Resource: 

 

You have successfully created an On-premises Data Gateway as Azure Service. 

On-premises Data Gateway must be selected on Azure Service like Azure Analysis Services that will use 

this gateway to receive On-premises data. 
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2.2. Creating Power BI Premium workspace 

1. Open Power BI portal, press Workspaces and Create a workspace. 

 

2. Name the workspace and select Premium per user under License mode 

 

3. Navigate to your Workspace 
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4. Press Settings button 

 

5. Select Premium tab and Premium per user option and copy Workspace Connection. 

Link should look like that: powerbi://api.powerbi.com/v1.0/myorg/BI4Dynamics%20PPU%20TEST 

 
 

2.3. Completing Power BI Premium option installation 

Open SQL Server Management Studio and connect to Power BI workspace. Newly created analysis 

database should have tables, which are currently still empty since data is not yet processed. 

 
 

Connect to local Database SQL server to check that instance database has been created. 

 
 

 

 

 

mailto:d
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The next step is to add this database as datasource. 

To do that open Power BI portal Settings and navigate to Manage gateways. 

 
Choose option Data Sources and press +New. 

  
Then fill in the following: 

• Choose Gateway cluster name (created during installation of On-premises data gateway) 

• Specify the Database and Data Source names (in our case they are the same for simplicity) 

• Choose Data Source Type as SQL Server 

• Specify your local Server name  

• Enter Authentication method as Windows and insert your credentials  

• Click Create  

  
Make sure that connection was established successfully. 
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Relate Power BI database with gateway datasource. To do that navigate to your workspace. 

 
Press three-dot sign and select Settings from the pop-up menu 

   
Under Gateway connection select the gateway you have installed on your computer and map gateway 

to the datasource used, click Apply. 

 
 

You have successfully created Gateway Connection 
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2.4. Installing Azure Analysis Services 

Analysis Services can be deployed on:  

A. Same computer that is hosting Data Warehouse  

Use this for BI development instance and when users connect to service that is running in LAN (local 

area network) 

B. As Azure Analysis Services 

Use this option (also described as Hybrid option) for most Production environments where users 

connect to service with AAD (Azure Active Directory). 

  

In this chapter option B is described.  

 Create Azure Analysis Services 

Before installing BI4Dynamics app you need to have available Azure Analysis Services that will host 

BI4Dynamics database. 

 

Go to Azure portal, find Analysis Services and click +Add  

 
 

Enter the following fields: 

- Server name: unique name of Analysis Server 

- Subscription 

- Resource group 

- Location 

- Pricing tier  

Database size (GB) will depend on data type, cardinality, and 

number of rows in your data warehouse  

QPUS (number of processing units) will depend on database size 

and number of users that will query the data 

 

Suggestion: start with lower tier, check if data can fit into database 

and if response time from your BI tool (Excel or Power BI) is good 

enough. If not, go for higher tier. It takes 60 seconds to change tier 

to next level. 

 

Click Create 

 
 

You have successfully created Azure Analysis Services  
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Go to resource and copy Server name to notepad as it will be used in BI4Dynamics app installation. 

 
 

In our example server name is: asazure://westeurope.asazure.windows.net/bi4dynamicshybrid 

 Connect to Azure Analysis Services 

To verify installation, connect to Analysis Services Server use SSMS (SQL Server Management Studio) 

and enter: 

Server Type: Analysis Services 

Server name 

Authentication: Azure Active Directory 

Username 

Password 

 

Here is a database that we have just created: 
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 Select On-Premises Data Gateway 

On-Premises Data Gateway is needed when Azure Service received data from On-Premises. When Azure 

Analysis Services is receiving data from On-Premises source than this option must be selected. 

 

Click on On-premises data gateway 

And Pick an On-Premises Data Gateway to connect 

 
Click Connect selected gateway. 

Gateway is now connected: 
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2.5. Implementation option - DFO/AX connector not available 

 Add Data Source (Dynamics 365 AX connector is not available at the time of 

installation) 

This chapter is about adding Data Source(s) without connecting to D365 F&O for Metadata and language 

settings. 

 

The solution is only temporary and has to be addresses later. Reasons for not being able to connect 

to D365 F&O could be different: credentials are not available, Azure portal services could not be setup. 

Consequences of Dynamics 365 AX connector not being available: 

• Metadata could not be loaded, thus impossible to have custom tables and columns in BI model. 

• Financial dimensions are not available, information on departments, cost centers, projects, etc. 

could not be got. 

 

1) Set Data Source Version. For D365 F&O that would be D365 On-Premises 

2) Type name of SQL Server Instance with data database. Type . (dot) if the field is empty. 

3) Select database from the pop-up menu. 

4) Select Windows Authentication as a method of Authentication. 

5) Test connection by clicking on Test connection to SQL Database button. 

6) Click on Add Data Source button and wait for source to be added. 

 Update instance from Metadata file 

Copy Metadata files from directory of sample instance to corresponding folders of the instance you have 

just created.  
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Go to Customize tab and click Get MetaData.  

Note: Make sure you are getting Metadata from instance folder 

 
 

Go back to step Selecting Global Dimensions and continue instance creation. 
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3. Managing instance 

3.1. Edit  

In order to edit existing BI4Dynamics instance do the following: 

1. Open instance 

2. Click on File and press Edit 

 

3. Make changes to instance. For example, in order to move analysis services to Azure change 

Authentication to “Azure Active Directory” and input username and password to Azure portal in 

the corresponding fields. 

 

4. Click Save & Restart Instance. 
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3.2. Copy instance 

In order to copy an existing BI4Dynamics instance do the following: 

 

Open instance, click on File and press Edit 

 

Check Copy current instance and enter name for the instance that you create. 

Note: all modifications, i.e. database name, analysis database name are saved to the copy, not current instance. 

 

Press Copy Instance button, button is disabled when entered settings are not valid - instance with such name 

already exists, connection to servers cannot be established, etc. 

 

Open copied instance, navigate to Deploy tab and Click on Deploy All. 
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Once the instance is successfully deployed open Customize tab, make sure Update from Instance folder is 

selected, and Get Metadata. 

 
As a last step, Open Process tab and click Process. 

 

3.3. Edit process flow 

Process flow is used to determine the sequence of execution of stored procedures when processing data 

with BI4Dynamics. Editing process flow is completely optional and it is usually connected with custom 

development.  

 Explanation of process flow top form functionality 

 

1. Edit existing Process flow or Add a new one 

2. Select Full or Incremental Processing type 

3. Process All (Stage, Data Warehouse and Analysis Database) 

4. Process just one on the above. 

5. Create SQL Agent Job (with the specified periodicity and start date) 

6. Process only Account Schedules instead of entire Analysis Database 

 

If you click on Edit SSIS, you will have the following tab and options on it: 

 

1. Reset the Process flow (return to original state) or Reload Process flow (include stored procedures 

saved in BI4Dynamics folder structure) 

2. Create a new Object Group (standard 1-13) 

3. Add or Remove a SSIS package from file 
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 Explanation of process flow table functionality 

  

1. Object group name.  

All stored procedures within object group are executed before the next Object group is executed. 

Each Object group forms a separate SSIS package which is executed on processing.  

2. Select/unselect a stored procedure to be executed on processing 

3. Run the stored procedure manually from the application 

4. Object subgroup name. Stored procedures within an Object subgroup are executed successively, 

while different Object subgroups within same Object group are executed in parallel.  

5. Rename Object Subgroup option 

 Moving stored procedure from one object group to another 

 
Right-click on a stored procedure gives you an option to move it to a different Object group if needed 

(on reset Process flow the stored procedure will be moved back to original Object subgroup).  

 Setting up process flow property manually in stored procedure 

Permanently moving a stored procedure to a different Object group is possible by adding a DECLARE 

clause in the stored procedure itself:  

 
By adding or changing declare statement store procedure’s execution flow is determined. 
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3.4. Manage Partitions 

Partitions divide portions of data you need to process (refresh) frequently from data that can be 

processed less frequently. For example, a fact table may include certain row sets that contain data that 

rarely changes, but other row sets have data that changes often. There's no need to process all of the 

data when only a portion of it needs to be processed. 

 

Partitions work by dividing a table into logical partition objects. Individual partitions, each containing a 

unique segment of data, can then be incrementally processed either sequentially or in parallel 

independent of other partitions, or excluded from processing operations altogether. 

 

This feature can be only used with SQL server enterprise edition or with Power BI premium. 

 

 

1. Open the Customize ribbon 

2. Select Manage Partitions 

 

1. Select the Cube. 

2. Select the Fact. 

3. Select the Date field to Partition by. 

4. Select the number of last partitions processed (this is determined by how much backdating is 

done). 

5. Deploy the fact. 

6. Process. 
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3.5. Setup BI4Dynamics precision 

Numeric data types can be stored in SQL with different precision, scale, and length.  

Precision is the total number of digits that can be stored both to the left and right of the decimal place.  

Scale is the number of digits to the right of the decimal point in a number. 

Length is the number of bytes that are used to store the number. 

 

In SQL the default maximum precision and scale for a particular length is the following: 

• 19,5   =   9 bytes 

• 27,10 = 13 bytes 

• 38,20 = 17 bytes  

During the installation, the following error might occur on stage: 

 

It should be addressed by increasing the precision (e.g. from 19 to 38) and scale (e.g. from 5 to 20). 

The default maximum precision of numeric and decimal data types is 38. 

To change it in application you need to: 

1. Open the instance and click File > Properties. 

 

2. Under Instance Setup > Data Warehouse Properties precision could be set up for: 

• Stage tables 

• Datawarehouse tables 
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3.6. Adding Calculation groups 

1. Open Tabular editor 

2. Go to File > Open > From DB 

3. Select the Server and Instance where you want to create calculation groups 

4. Select Model and New Calculation group 

 

5. Add new Calculation items with DAX query  

 

6. Right click the new Calculation group, select Script > Create or Replace > To Clipboard 
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7. Open BI4Dynamics application and open instance 

8. Go to Customize tab > Manage Dimensions 

 

9. Select New Calc. Group, add a name and copy the script 

 

 

10. Update and Generate all under Calculation groups 

11. Deploy and Process analysis database 

3.7. Deleting instance 

1. Open the instance you would like to delete by clicking File and selecting the instance in the list 

on the right. 

2. Click File > Delete. 

3. Click Yes to confirm the action. 

IMPORTANT! When deleting an instance, the Data Warehouse and Analysis Database will be deleted.  

Note: BI4Dynamics Instance folders and the log file are not removed during the delete process.  

Uninstalling BI4Dynamics 

1. Click Start > Settings > Control Panel. 

2. Click Add or Remove Programs. 

3. From the list of installed programs, select BI4Dynamics. 

4. Click Remove. 

5. Follow the instructions on screen. 

IMPORTANT! User files will not be removed when uninstalling the solution. 
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4. Connecting Excel and Power BI reports 

4.1. Downloading Excel and Power BI reports 

1. Open Instance 

2. Go to Install tab 

3. Click Download reports 

4. Select the destination 

5. Standard reports will be downloaded that are included with BI4Dynamics 

4.2. Connecting Power BI reports 

 Changing connection 

1. Open Power BI report 

2. Click Edit Queries > Data source settings 

 

3. Type the Server name to the Server field. Type the Database name to the Database field 

 

 Creating a new connection 

4. Open Power BI Desktop 

5. Click Get data 

6. Choose Analysis Services 

7. Type the Server name and Database name 

8. Choose Connect live 
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9. Click OK and start exploring your data 

You should see this screen: 

 

4.3. Connecting Excel reports  

 Changing connection 

1. Open Excel report 

2. Click Data > Connections > Properties >Definition 

3. Type the database name to the Initial Catalog property of the 

Connection string. Type the Server name to the Data Source 

property of the Connection string. 

 

 Creating a new connection 

4. Open Microsoft Excel 

5. Click Data > Get External Data > From other Data Source > From Analysis Services. 

 

6. Insert a Server name      

 
do not enter “.” for local server as this connection will not work on another PC 
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7. Click Next and select Analysis database from the dropdown menu and select Model 

  

 

8. Click Finish and OK on next form. 

 

You have successfully connected Excel to Analysis Services model. 

 

Start exploring your data by dragging and dropping dimensions and measures in pivot table 

 

You have successfully connected Power BI to Analysis Services model. 


