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1. Installation of BI4Dynamics application 

Installation documentation consists of documents: 

1. Installation of BI4Dynamics application (covered by this document) 

2. Installation of BI server on Local Machine or Azure Virtual Machine (VM) 

1.1. Implementation options  

 

Business Central

Azure Data Lake

Blob Storage

Data Warehouse

(BI4Dynamics)

On-Premises

Web services export BC tables as CSV files

CSV files are loaded into staging area

Data storage

Source

Data 

processing

Visualize

Power BI             Excel

Azure Power BI Premium

A B C

 
 

 
Local Analytics  

(A) 

Azure Analytics 

(B) 

Power BI Premium 

(C) 

Install Gateway ✖ On-Premises Data gateway 

Create new instance ✖ ✔ ✔ 

Add data source BC cloud BC cloud BC cloud 

Install data warehouse ✔ ✔ ✔ 

Export data to Blob Storage ✔ ✔ ✔ 

Map Gateway to Data source ✖ ✖ ✔ 

Process instance ✔ ✔ ✔ 
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1.2. Prerequisites 

1.2.1. BC credentials 

Description Value 

BC Admin User adminuser@bi4dynamics.onmicrosoft.com 

BC Admin User Password rtPxXqxJ2lkOIJFR9Eki#8 

1.2.2. Information about Azure SQL Virtual Machine and Azure Storage 

All prerequisite fields are result of that Local or VM installation (fields here are for example only): 

 

Azure Storage: 

Description Value 

Subscription Pay-As-You-Go 

Resource Group vm-bi4-demo 

Azure Storage Account  vmbi4demostorage 

Storage Account Blob Key 4T+eDbv9U7G7Wd785S0P86V++VBdqIaPeTTHHvun1lGgN4I== 

 

Azure Container instance: 

Description Value 

Subscription Pay-As-You-Go 

Container Instance  vmbi4democontainer 

1.2.3. Implementation options for analytical database 

Azure Analysis Services – implementation option B: 

Description Value 

Azure Analysis Services asazure://westeurope.asazure.windows.net/bi4dynamicshybrid 

Username (AAS admin) mg@bi4dynamics.com 

Password Qpewoicsj490wkss 

 

Power BI Premium – implementation option C: 

Description Value 

Workspace connection Power BI://api.Power BI.com/v1.0/myorg/BI4Dynamics%20PPU% 

Username (Power BI) mg@bi4dynamics.com 

Password Qpewoicsj490wkss 

  

mailto:adminuser@bi4dynamics.onmicrosoft.com
mailto:mg@bi4dynamics.com
mailto:mg@bi4dynamics.com
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1.3. Installing BI4Dynamics application 

1.3.1. Install BI4Dynamics extension to BC tenant 

Install BI4Dynamics BC Extension to your BC tenant. Extension must be installed on Production 

environment. As this is a standard BC installation, we will not describe steps. 

https://www.bi4dynamics.com/dl/azure/APP.zip 

 

 
 

Any other extensions you might be using in BC and plan to include in the BI project must be installed 

on Production and on the Sandbox environment.  

Microsoft does not permit reading all the extension information (Symbols) directly from Production 

environment, therefore BI4Dynamics is using the Sandbox environment to read the Symbols (extension 

Metadata). 

 

1.3.2. Install desktop BI4Dynamics application 

IMPORTANT! Before installing BI4Dynamics, please check hardware and software requirements, make 

sure you have sufficient permissions and an active internet connected. 

IMPORTANT! The installation process must be started on VM where BI4Dynamics Data Warehouse will 

be created. 

1. Double-click BI4Dynamics.exe to start the installation*.  

*Always start BI4Dynamics as an administrator. 

Note: The name of the file varies based on the version you are using. 

2. Follow the instructions on screen and Accept the license agreement. 

 

  

https://www.bi4dynamics.com/dl/azure/APP.zip
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3. Choose the Default option. 

 

4. The installer will check for some of the prerequisites. If you fail any of the tests you can click on 

the result to see the error. You must fix the problem before you can rerun the test. Once all the 

tests are successfully completed you can continue with the installation. 

 

5. If a correct version of Shared Management Objects, Analysis Management Objects or .NET 

Framework are not installed, please click the Install button, which will trigger the installation of 

correct version of SMO’s, AMO’s, CLR Types or .NET Framework. 
 

6. Select the folder where you would like to install BI4Dynamics. You can choose to create a shortcut 

on the desktop and/or in the start menu. 
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7. Confirm the configuration and begin the installation of BI4Dynamics. 

8. Click Finish after the installation is completed. 
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1.4. Creating BI4Dynamics instance 

Deploying a BI4Dynamics solution is a six-step process: 

1. Providing license information 

2. Creating an instance 

3. Adding the data sources 

4. Selecting companies 

5. Selecting Azure Framework module 

6. Deploying and processing model 

When you open the application, an instance wizard will start to guide you through the configuration. 

1.4.1. Providing license information 

1. Launch BI4Dynamics.exe from the folder where BI4Dynamics was installed to open application. 

 
Note: BI4Dynamics is 64-bit application, but the default installation location is C:\Program Files 

(x86)\BI4Dynamics NAV. Application can also be started from the Desktop shortcut or from the Start Menu 

shortcut. 

2. Enter the BI4Dynamics online license key   

     OR 

Follow the instructions on screen to receive an offline license key (in case you do not have the 

internet connection or port 80 on the server is closed). 

 
Note: If you experience any problems with authorization, please contact us via support@bi4dynamic.com.  

3. Click Next. 

mailto:support@bi4dynamic.com


BI4Dynamics BC Cloud - Installation Manual Page 9 

2. Implementation option A: Local Analysis Services 

2.1. Creating Instance 

2.1.1. Step 1: Create a new instance 

Instance properties 

1. Check the Source is BC Cloud checkbox. 

2. Type the Name of the new instance. 

3. Select what Language the solution will be deployed in.  

SQL server 

1. Keep or change Database Name of the BI4Dynamics Data Warehouse.  

2. Type SQL server name 

3. Select or Type in the SQL Server Instance name where the BI4Dynamics Data Warehouse will be 

deployed. 

4. Authentication type: Windows 

 

Analysis Services 

1. Keep or change the Analysis Database Name of the Analysis Services instance. 

2. Keep or change the Analysis Database Server name where the Analysis Services model will be 

deployed. 

3. Authentication type: Windows 

2.1.2. Step 2: Test installed resources 

This is the current setting on the form, and we continue with installation:    
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Integration Services 

Check SQL Integration Service to process BI4Dynamics 

using the Integration services (parallel processing). 

Refresh 

Click Refresh to set default values for SQL Database 

file Locations (data and log files) and SQL Database 

Collation are entered automatically. Modify if 

necessary. 

Test 

Please note that  

- VM is for installation on of Azure SQL VM  

- Local is for local server installation  

We are testing more resources on VM than on Local. 

 

Click VM or Local to test resources that must be installed on VM or Local Machine to proceed with BC 

installation.  Diagnostics message should confirm that all resources are available, set and running. In case 

any of these shows ERROR, stop BC installation and fix the reported service error. This should be the 

message: 

 

 
Continue and click Refresh to update file locations 

Click Next. 

2.1.3. Step 3: Add Data Source 

Azure Storage Information 

This information is about Azure Storage Account that will be used to keep BC data. The values have 

been created during VM installation and are listed as a prerequisite for BC application installation. 

1. Type Subscription that is used for Storage Account 

2. Type Virtual Machine Resource Group as VM Resource Group 

3. Type Storage Account Name 

4. Type Container Name  (this resource should not be confused for Container instance aca Docker, 

that is another Azure resource, used for exporting tables to Storage Account) 

5. Type Blob Key 

Click Test to check if the entered information is correct. 
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Click Test to test entered information.  

A new window will require authentication. Enter Azure portal admin user and password: 

 
Installation of Azure authentication modules will start. Enter A to confirm installation of all modules 

 
Wait few minutes to start downloading and installing packages 

 
On finish this message pop-us to confirm that resources are entered correctly: 

 

Business Central 

Click Login to login into Azure with BC admin credentials. 

 



BI4Dynamics BC Cloud - Installation Manual Page 12 

A new window will open: 

 
Enter username and password for BC admin (first time) 

 

After entering password wait 15 seconds to sign in again. In this process, BC admin will allow BI4Dynamics 

application to access BC data. Enter BC admin credentials (second time): 

 

Sometimes, account login does not work correctly. Use option Use another account and enter the same 

BC admin account credentials. 

 

 

 

 

 

 

 

 

 

 

New window will pop-up: 

 

 

 

 

 

 

 

 

 

 

 

 

Click Accept and wait … 
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Application will automatically fill-in BC Tenant ID and App Registration Client ID: 

(You can enter this information if you have it from previous process without login process) 

 

 
 

Select BC environment and click Initialize Data Lake. 

 

 
 

After Initializing click Add to add the selected data source and wait…  

Your screen should look like this: 

 

You have successfully added data source 

 

Click Next. 
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2.1.4. Step 4: Selecting Companies and Global Dimensions 

1. From the list of companies tick the ones you want to include in your instance and configure 

additional settings for each selected company: 

a. Company short name: User-friendly name (e.g. ME) 

Country and Local Currency are read from BC (no input). 

b. Additional Currency: select the additional currency for this company (e.g. USD);  

Transaction values in local currency will be recalculated by exchange rate valid at transaction 

date to values in additional currency (ACY). There are few hundred ACY measures. 

c. Dimensions:  

i. Click Initialize global dimensions (delete the dimension by clicking the X button next to 

the dimension name if one or more dimensions will not be used in the project). 

We suggest adding a prefix or suffix (“dim” or “Dim”) to global dimension name, so that 

▪ global dimensions are easier to find in the front-end tool (Excel, Power BI) and  

▪ we have unique name in application (you may have global dimension “Job” which is 

also a standard BI4Dynamics dimension, having two with same name will cause an 

error). 

ii. Click Add dimension to add the company dimensions and map it to corresponding global 

dimension. Mapping is done automatically, but you can manually change it if needed.  

Delete the dimension by clicking the X button next to the dimension name 

iii. Continue adding and mapping dimensions for other selected companies. Only click Initialize 

global dimension if there are additional dimensions that are not present in the first company. 

 

2. Click Next. 
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2.1.5. Step 5: Selecting Modules 

Select Modules you would like to apply to your instance:  

 
Click Next. 

2.1.6. Step 6: Finishing the setup 

In the last step please click Close (do not click Run) 
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2.1.7. Step 7: Installing Data Warehouse and Analytics 

Open Deploy tab and make sure Keep Data Warehouse and Keep Analysis Database are checked 

 
Move to Install tab and click Installation button. 

 
 

On the Installation screen, uncheck #9 Process Instance, click Run 

 
Wait for the “Installation Completed” message. 

 

 

 

 

 

 

You have successfully deployed data warehouse and analytics. 
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2.2. Exporting data from BC to Blob Storage 

We want to get table data from BC to data warehouse. The first step is to get data from BC to Blob 

Storage. This process is triggered by running Container instance. In installation process now, we will run 

the process manually, to immediately get data from BC to Blob Storage. Later, this is triggered by daily 

job. 

 

Run Container Instance to export data from BC Cloud to Blob Storage (in Azure portal): 

 

 
 

Wait until the process is finished. It can take 30 minutes for database with few million records. 
 

You have successfully exported data from BC to Blob Storage 
 

2.3. Processing instance (DW and analytics) 

On the Installation screen, please check #9 Process Instance, click Run  

 

 
 

 

Wait for the “Installation Completed” message. 

 

 

You have successfully installed data warehouse and analytics. 
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3. Implementation option B: Azure Analysis Services 

When you choose to install analytics as Azure Analysis Services, you need to install following: 

- Azure Analysis Service in Azure portal 

- On-Premises Gateway on your BI server 

We recommend to first install On-premises Gateway and later Azure Analysis Services as we enter 

parameters from on-Premises gateway to Azure Analysis Service settings. 

3.1. Installing On-premises Data Gateway 

On-premises data gateway is needed when connecting to Azure Analysis Service. This requires two steps: 

1. Install On-Premises data gateway on local computer 

2. Configure On-Premises data gateway field in Azure Analysis Services by selecting the On-Premises 

data gateway 

3.1.1. Install On-Premises data gateway on virtual machine 

Download On-Premises data gateway to virtual machine 

Download On-Premises Data gateway from Microsoft site: 

https://www.microsoft.com/en-us/download/details.aspx?id=53127 

 

Install On-premises data gateway 

Follow the documentation from Microsoft site: 

https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-install 

 

Note: Please be very careful when selecting the right region.  Installation process will set On-Premises 

Gateway to your default region, that may not be the same as Azure Analysis Services. The feature is not 

so exposed during installation so it can easily go unnoticed. 

 

 

If you have set the wrong Region, and your Gateway does not appear in the available list of gateways of 

your Azure Analysis Services than you must re-install On-Premises data gateway. 

https://www.microsoft.com/en-us/download/details.aspx?id=53127
https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-install
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3.1.2. Setup On-premises Data Gateway as Azure Service 

Go to Azure portal  

Click on icon On-premises Data Gateway 

 
Click on + New 

 

Enter all fields: 

Resource name 

Subscription 

Resource group 

Location 

Installation name: select on-premises gateway that you have 

created in previous step from the list of available gateways 

 

Then click Create 

 

Click Go to Resource: 

 

You have successfully created an On-premises Data Gateway as Azure Service. 

On-premises Data Gateway must be selected on Azure Service like Azure Analysis Services that will use 

this gateway to receive On-premises data. 
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3.2. Installing Azure Analysis Services 

3.2.1. Create Azure Analysis Services 

Before installing BI4Dynamics app you need to have available Azure Analysis Services that will host 

BI4Dynamics database. 

 

Go to Azure portal, find Analysis Services and click +Add  

 
 

Enter the following fields: 

- Server name: unique name of Analysis Server 

- Subscription 

- Resource group 

- Location 

- Pricing tier  

Database size (GB) will depend on data type, cardinality, and 

number of rows in your data warehouse  

QPUS (number of processing units) will depend on database size 

and number of users that will query the data 

 

Suggestion: start with lower tier, check if data can fit into database 

and if response time from your BI tool (Excel or Power BI) is good 

enough. If not, go for higher tier. It takes 60 seconds to change tier 

to next level. 

 

Click Create 

 
 

You have successfully created Azure Analysis Services 
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Go to resource and copy Server name to notepad as it will be used in BI4Dynamics app installation. 

 
 

In our example server name is: asazure://westeurope.asazure.windows.net/bi4dynamicshybrid 

3.2.2. Connect to Azure Analysis Services 

To verify installation, connect to Analysis Services Server use SSMS (SQL Server Management Studio) 

and enter: 

Server Type: Analysis Services 

Server name 

Authentication: Azure Active Directory 

Username 

Password 

 

Here is a database that we have just created: 
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3.2.3. Select On-Premises Data Gateway 

On-Premises Data Gateway is needed when Azure Service received data from On-Premises. When Azure 

Analysis Services is receiving data from On-Premises source than this option must be selected. 

 

Click on On-premises data gateway 

And Pick an On-Premises Data Gateway to connect 

 
Click Connect selected gateway. 

Gateway is now connected: 
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3.3. Creating Instance 

3.3.1. Step 1: Create a new instance 

 

Instance properties 

1. Check the Source is BC Cloud checkbox. 

2. Type the Name of the new instance. 

3. Select what Language the solution will be deployed in 

SQL server 

As we are moving Analytics to Azure, we also need to move credential information to Azure Analysis 

Services. Authentication for SQL server will be saved to Azure Analysis Services string connection as 

Account impersonation.  

When choosing Azure Active Directory in Analysis Services setup, a new Authentication window will open 

for SQL Server. Please enter: 

• Username: same user in DOMAIN\adminuser format 

• Password: password for this user 

 

Analysis Services 

• Check the Source is BC Cloud checkbox. 

• Analysis Server name: enter the name of the Azure Analysis Services  

Authentication: Azure Active Directory 

Username: email of the admin user (adminuser@domain.com) that has been entered when creating 

Azure Analysis Services 

Password: enter password for Azure Active Directory  

3.3.2. Step 2: Test installed resources 

This is the current setting on the form, and we continue with installation:    

mailto:adminuser@domain.com
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Integration Services 

Check SQL Integration Service to process BI4Dynamics 

using the Integration services (parallel processing). 

Refresh 

Click Refresh to set default values for SQL Database 

file Locations (data and log files) and SQL Database 

Collation are entered automatically. Modify if 

necessary. 

Test 

Please note that  

- VM is for installation on of Azure SQL VM  

- Local is for local server installation  

We are testing more resources on VM than on Local. 

 

Click VM or Local to test resources that must be installed on VM or Local Machine to proceed with BC 

installation.  Diagnostics message should confirm that all resources are available, set and running. In case 

any of these shows ERROR, stop BC installation and fix the reported service error. This should be the 

message: 

 

 
Continue and click Refresh to update file locations 

Click Next. 
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3.3.3. Step 3: Add Data Source 

Azure Storage Information 

This information is about Azure Storage Account that will be used to keep BC data. The values have 

been created during VM installation and are listed as a prerequisite for BC application installation. 

1. Type Subscription that is used for Storage Account 

2. Type Virtual Machine Resource Group as VM Resource Group 

3. Type Storage Account Name 

4. Type Container Name  (this resource should not be confused for Container instance aca Docker, 

that is another Azure resource, used for exporting tables to Storage Account) 

5. Type Blob Key 

Click Test to check if the entered information is correct. 

 
 

Click Test to test entered information.  

A new window will require authentication. Enter Azure portal admin user and password: 

 
Installation of Azure authentication modules will start. Enter A to confirm installation of all modules 

 
Wait few minutes to start downloading and installing packages 

 
On finish this message pop-us to confirm that resources are entered correctly: 
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Business Central 

Click Login to login into Azure with BC admin credentials. 

 
 

A new window will open: 

 
Enter username and password for BC admin (first time) 

 

After entering password wait 15 seconds to sign in again. In this process, BC admin will allow BI4Dynamics 

application to access BC data. Enter BC admin credentials (second time): 

 

Sometimes, account login does not work correctly. Use option Use another account and enter the same 

BC admin account credentials. 
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New window will pop-up: 

 

 

 

 

 

 

 

 

 

 

 

 

Click Accept and wait … 

 

Application will automatically fill-in BC Tenant ID and App Registration Client ID: 

(You can enter this information if you have it from previous process without login process) 

 

 
 

Select BC environment and click Initialize Data Lake. 
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After Initializing click Add to add the selected data source and wait…  

Your screen should look like this: 

 

You have successfully added data source 

 

Click Next. 
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3.3.4. Step 4: Selecting Companies and Global Dimensions 

3. From the list of companies tick the ones you want to include in your instance and configure 

additional settings for each selected company: 

a. Company short name: User-friendly name (e.g. ME) 

Country and Local Currency are read from BC (no input). 

b. Additional Currency: select the additional currency for this company (e.g. USD);  

Transaction values in local currency will be recalculated by exchange rate valid at transaction 

date to values in additional currency (ACY). There are few hundred ACY measures. 

c. Dimensions:  

i. Click Initialize global dimensions (delete the dimension by clicking the X button next to 

the dimension name if one or more dimensions will not be used in the project). 

We suggest adding a prefix or suffix (“dim” or “Dim”) to global dimension name, so that 

▪ global dimensions are easier to find in the front-end tool (Excel, Power BI) and  

▪ we have unique name in application (you may have global dimension “Job” which is 

also a standard BI4Dynamics dimension, having two with same name will cause an 

error). 

ii. Click Add dimension to add the company dimensions and map it to corresponding global 

dimension. Mapping is done automatically, but you can manually change it if needed.  

Delete the dimension by clicking the X button next to the dimension name 

iii. Continue adding and mapping dimensions for other selected companies. Only click Initialize 

global dimension if there are additional dimensions that are not present in the first company. 

 

4. Click Next. 
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3.3.5. Step 5: Selecting Modules 

Select Modules you would like to apply to your instance:  

 
Click Next. 

3.3.6. Step 6: Finishing the setup 

In the last step please click Close (do not click Run) 
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3.3.7. Step 7: Installing Data Warehouse and Analytics 

Open Deploy tab and make sure Keep Data Warehouse and Keep Analysis Database are checked 

 
Move to Install tab and click Installation button. 

 
 

On the Installation screen, uncheck #9 Process Instance, click Run 

 
Wait for the “Installation Completed” message. 

 

 

 

 

 

 

You have successfully deployed data warehouse and analytics. 
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3.4. Exporting data from BC to Blob Storage 

We want to get table data from BC to data warehouse. The first step is to get data from BC to Blob 

Storage. This process is triggered by running Container instance. In installation process now, we will run 

the process manually, to immediately get data from BC to Blob Storage. Later, this is triggered by daily 

job. 

 

Run Container Instance to export data from BC Cloud to Blob Storage (in Azure portal): 

 

 
 

Wait until the process is finished. It can take 30 minutes for database with few million records. 
 

You have successfully exported data from BC to Blob Storage 
 

3.5. Processing instance (DW and analytics) 

On the Installation screen, please check #9 Process Instance, click Run  

 

 
 

Wait for the “Installation Completed” message. 

 

You have successfully installed data warehouse and analytics. 
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4. Implementation option C: Power BI Premium 

4.1. Installing On-premises Data Gateway 

Download On-Premises data gateway to virtual machine 

Download On-Premises Data gateway from Microsoft site: 

https://www.microsoft.com/en-us/download/details.aspx?id=53127 

 

Install On-premises data gateway 

Follow the documentation from Microsoft site: 

https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-install 

 

Note: Please be very careful when selecting the right region.  Installation process will set On-Premises 

Gateway to your default region that may not be the same as Azure Analysis Services. The feature is not 

so exposed during installation so it can easily go unnoticed. 

 

 

If you have set the wrong Region, and your Gateway does not appear in the available list of gateways of 

your Azure Analysis Services than you must re-install On-Premises data gateway. 

 

 

 

 

 

 

 

 

 

 

 

https://www.microsoft.com/en-us/download/details.aspx?id=53127
https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-install
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4.2. Creating Power BI workspace 

1. Open Power BI portal, press Workspaces and Create a workspace. 

 

2. Name the workspace and select Premium per user under License mode. 
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3. Navigate to your Workspace. 

 

4. Press Settings button. 

 

5. Select Premium tab and Premium per user option and copy Workspace Connection. 

Link should look like that: powerbi://api.powerbi.com/v1.0/myorg/BI4Dynamics%20PPU%20TEST  

 

  

mailto:d
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4.3. Creating Instance 

4.3.1. Step 1: Create a new instance 

 
 

Instance properties 

1. Check the Source is BC Cloud checkbox. 

2. Type the Name of the new instance. 

3. Select what Language the solution will be deployed in 

SQL server 

• SQL Server Name: name of the server DW will be installed on 

Authentication: Windows 

Analysis Services 

• Check the Source is BC Cloud checkbox. 

• Analysis Server Option: Power BI (XMLA endpoint) 

Workspace: connection link to the Power BI workspace that you have created in the previous steps 

Authentication: Azure Active Directory 

Username: Power BI Premium user email (adminuser@domain.com)  

Password: password for Azure Active Directory  

4.3.2. Step 2: Test installed resources 

This is the current setting on the form, and we continue 

with installation:    

Integration Services 

Check SQL Integration Service to process BI4Dynamics 

using the Integration services (parallel processing). 

Refresh 

Click Refresh to set default values for SQL Database file 

Locations (data and log files) and SQL Database Collation are entered automatically. Modify if 

necessary. 

Test 

Please note that  

- VM is for installation on of Azure SQL VM  

- Local is for local server installation  

We are testing more resources on VM than on Local. 

 

mailto:adminuser@domain.com
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Click VM or Local to test resources that must be installed on VM or Local Machine to proceed with BC 

installation.  Diagnostics message should confirm that all resources are available, set and running. In case 

any of these shows ERROR, stop BC installation and fix the reported service error. This should be the 

message: 

 

 
Continue and click Refresh to update file locations 

Click Next. 

4.3.3. Step 3: Add Data Source 

Azure Storage Information 

This information is about Azure Storage Account that will be used to keep BC data. The values have 

been created during VM installation and are listed as a prerequisite for BC application installation. 

1. Type Subscription that is used for Storage Account 

2. Type Virtual Machine Resource Group as VM Resource Group 

3. Type Storage Account Name 

4. Type Container Name  (this resource should not be confused for Container instance aca Docker, 

that is another Azure resource, used for exporting tables to Storage Account) 

5. Type Blob Key 

Click Test to check if the entered information is correct. 

 
 

Click Test to test entered information.  

A new window will require authentication. Enter Azure portal admin user and password: 

 
Installation of Azure authentication modules will start. Enter A to confirm installation of all modules 
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Wait few minutes to start downloading and installing packages 

 
On finish this message pop-us to confirm that resources are entered correctly: 

 

Business Central 

Click Login to login into Azure with BC admin credentials. 

 
 

A new window will open: 

 
Enter username and password for BC admin (first time) 

 

After entering password wait 15 seconds to sign in again. In this process, BC admin will allow BI4Dynamics 

application to access BC data. Enter BC admin credentials (second time): 
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Sometimes, account login does not work correctly. Use option Use another account and enter the same 

BC admin account credentials. 

 

 

 

 

 

 

 

 

 

New window will pop-up: 

 

 

 

 

 

 

 

 

 

 

 

 

Click Accept and wait … 

 

Application will automatically fill-in BC Tenant ID and App Registration Client ID: 

(You can enter this information if you have it from previous process without login process) 
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Select BC environment and click Initialize Data Lake. 

 

 
 

After Initializing click Add to add the selected data source and wait…  

Your screen should look like this: 

 

You have successfully added data source 

 

Click Next. 
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4.3.4. Step 4: Selecting Companies and Global Dimensions 

5. From the list of companies tick the ones you want to include in your instance and configure 

additional settings for each selected company: 

a. Company short name: User-friendly name (e.g. ME) 

Country and Local Currency are read from BC (no input). 

b. Additional Currency: select the additional currency for this company (e.g. USD);  

Transaction values in local currency will be recalculated by exchange rate valid at transaction 

date to values in additional currency (ACY). There are few hundred ACY measures. 

c. Dimensions:  

i. Click Initialize global dimensions (delete the dimension by clicking the X button next to 

the dimension name if one or more dimensions will not be used in the project). 

We suggest adding a prefix or suffix (“dim” or “Dim”) to global dimension name, so that 

▪ global dimensions are easier to find in the front-end tool (Excel, Power BI) and  

▪ we have unique name in application (you may have global dimension “Job” which is 

also a standard BI4Dynamics dimension, having two with same name will cause an 

error). 

ii. Click Add dimension to add the company dimensions and map it to corresponding global 

dimension. Mapping is done automatically, but you can manually change it if needed.  

Delete the dimension by clicking the X button next to the dimension name 

iii. Continue adding and mapping dimensions for other selected companies. Only click Initialize 

global dimension if there are additional dimensions that are not present in the first company. 

 

6. Click Next. 
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4.3.5. Step 5: Selecting Modules 

Select Modules you would like to apply to your instance:  

 
Click Next. 

4.3.6. Step 6: Finishing the setup 

In the last step please click Close (do not click Run) 
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4.3.7. Step 7: Installing Data Warehouse and Analytics 

Open Deploy tab and make sure Keep Data Warehouse and Keep Analysis Database are checked 

 
Move to Install tab and click Installation button. 

 
 

On the Installation screen, uncheck #9 Process Instance, click Run 

 
Wait for the “Installation Completed” message. 

 

 

 

 

 

 

You have successfully deployed data warehouse and analytics. 
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4.4. Exporting data from BC to Blob Storage 

We want to get table data from BC to data warehouse. The first step is to get data from BC to Blob 

Storage. This process is triggered by running Container instance. In installation process now, we will run 

the process manually, to immediately get data from BC to Blob Storage. Later, this is triggered by daily 

job. 

 

Run Container Instance to export data from BC Cloud to Blob Storage (in Azure portal): 

 

 
 

Wait until the process is finished. It can take 30 minutes for database with few million records. 
 

You have successfully exported data from BC to Blob Storage 
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4.5. Setup On-Premises Data Gateway 

Open SQL Server Management Studio and connect to Power BI workspace. Newly created analysis 

database should have tables, which are currently still empty, since data is not yet processed. 

 
 

Connect to local Database SQL server to check that instance database has been created. 

 
 

The next step is to add this database as datasource. 

To do that open Power BI portal Settings and navigate to Manage gateways. 

 
 

Choose option Data Sources and press +New. 

  
 

 

 

Then fill in the following: 

• Choose Gateway cluster name (created during installation of On-premises data gateway) 
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• Specify the Database and Data Source names (in our case they are the same for simplicity) 

• Choose Data Source Type as SQL Server 

• Specify your local Server name  

• Enter Authentication method as Windows and insert your credentials  

• Click Create  

  
Make sure that connection was established successfully. 

 

Relate Power BI database with gateway datasource. To do that navigate to your workspace. 
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Press three-dot sign and select Settings from the pop-up menu 

   
 

Under Gateway connection select the gateway you have installed on your computer and map gateway 

to the datasource used, then click Apply. 
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4.6. Processing instance (DW and analytics) 

Open BI4Dynamics application and move to Install tab and click Installation button. 

 
Select #9 Process Instance and click Run. 

 
Wait for the “Installation Completed” message. 

 

You have successfully installed data warehouse and analytics. 
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5. Managing instance 

5.1. Edit instance 

To edit existing BI4Dynamics instance do the following: 

1. Open instance 

2. Click on File and press Edit 

 

3. Make changes to instance. For example, in order to move analysis services to Azure change 

Authentication to “Azure Active Directory” and input username and password to Azure portal in 

the corresponding fields. 

 

4. Click Save & Restart Instance. 

 

 

 



BI4Dynamics BC Cloud - Installation Manual Page 50 

5.2. Copy instance 

To copy an existing BI4Dynamics instance do the following: 

5. Open instance 

6. Click on File and press Edit 

 

7. Check Copy current instance and enter name for the instance that you create. 

4. Note: copy name and all other modifications, i.e. database name, analysis database name are saved to 

the copy, not current instance. 

 

8. Press Copy Instance button, button is disabled when entered settings are not valid - instance with such 

name already exists, connection to servers cannot be established, etc. 

9. Open copied instance, navigate to Deploy tab and Click on Deploy All. 
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10.  Once the instance is successfully deployed open Customize tab, make sure Update from Instance 

folder is selected, and Get Metadata. 

 

11. As a last step, Open Process tab and click Process. 

 
 

5.3. Edit process flow 

Process flow is used to determine the sequence of execution of stored procedures when processing data 

with BI4Dynamics. Editing process flow is completely optional and it is usually connected with custom 

development.  

5.3.1. Explanation of process flow top form functionality 

 

1. Edit existing Process flow or Add a new one 

2. Select Full or Incremental Processing type 

3. Process All (Stage, Data Warehouse and Analysis Database) 

4. Process just one on the above. 

5. Create SQL Agent Job (with the specified periodicity and start date) 

6. Process only Account Schedules instead of entire Analysis Database 

 

If you click on Edit SSIS, you will have the following tab and options on it: 

 

1. Reset the Process flow (return to original state) or Reload Process flow (include stored procedures 

saved in BI4Dynamics folder structure) 

2. Create a new Object Group (standard 1-13) 

3. Add or Remove a SSIS package from file 
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5.3.2. Explanation of process flow table functionality 

  

1. Object group name.  

All stored procedures within object group are executed before the next Object group is executed. 

Each Object group forms a separate SSIS package which is executed on processing.  

2. Select/unselect a stored procedure to be executed on processing 

3. Run the stored procedure manually from the application 

4. Object subgroup name. Stored procedures within an Object subgroup are executed successively, 

while different Object subgroups within same Object group are executed in parallel.  

5. Rename Object Subgroup option 

5.3.3. Moving stored procedure from one object group to another 

 
Right-click on a stored procedure gives you an option to move it to a different Object group if needed 

(on reset Process flow the stored procedure will be moved back to original Object subgroup).  

5.3.4. Setting up process flow property manually in stored procedure 

Permanently moving a stored procedure to a different Object group is possible by adding a DECLARE 

clause in the stored procedure itself:  

 
By adding or changing declare statement store procedure’s execution flow is determined. 
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5.4. Manage Partitions 

Partitions divide portions of data you need to process (refresh) frequently from data that can be 

processed less frequently. For example, a fact table may include certain row sets that contain data that 

rarely changes, but other row sets have data that changes often. There's no need to process all of the 

data when only a portion of it needs to be processed. 

 

Partitions work by dividing a table into logical partition objects. Individual partitions, each containing a 

unique segment of data, can then be incrementally processed either sequentially or in parallel 

independent of other partitions, or excluded from processing operations altogether. 

 

This feature can be only used with SQL server enterprise edition or with PowerBI premium. 

 

 
 

1. Open the Customize ribbon 

2. Select Manage Partitions 

 
 

 

1. Select the Cube. 

2. Select the Fact. 

3. Select the Date field to Partition by. 

4. Select the number of last partitions processed (this is determined by how much backdating is 

done). 

5. Deploy the fact. 

6. Process. 
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5.5. Setup BI4Dynamics precision 

Numeric data types can be stored in SQL with different precision, scale, and length.  

Precision is the total number of digits that can be stored both to the left and right of the decimal place.  

Scale is the number of digits to the right of the decimal point in a number. 

Length is the number of bytes that are used to store the number. 

 

In SQL the default maximum precision and scale for a particular length is the following: 

• 19,5   =   9 bytes 

• 27,10 = 13 bytes 

• 38,20 = 17 bytes  

During the installation, the following error might occur on stage: 

 

It should be addressed by increasing the precision (e.g. from 19 to 38) and scale (e.g. from 5 to 20). 

The default maximum precision of numeric and decimal data types is 38. 

To change it in application you need to: 

1. Open the instance and click File > Properties. 

 

2. Under Instance Setup > Data Warehouse Properties precision could be set up for: 

• Stage tables 

• Datawarehouse tables 
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5.6. Adding Calculation groups 

1. Open Tabular editor 

2. Go to File > Open > From DB 

3. Select the Server and Instance where you want to create calculation groups 

4. Select Model and New Calculation group 

 

5. Add new Calculation items with DAX query  

 

6. Right click the new Calculation group, select Script > Create or Replace > To Clipboard 
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7. Open BI4Dynamics application and open instance 

 

8. Go to Customize tab > Manage Dimensions 

9. Select New Calc. Group, add a name and copy the script 

 

 

10. Update and Generate all under Calculation groups 

11. Deploy and Process analysis database 

5.7. Deleting instance 

1. Open the instance you would like to delete by clicking File and selecting the instance in the list 

on the right. 

2. Click File > Delete. 

3. Click Yes to confirm the action. 

IMPORTANT! When deleting an instance, the Data Warehouse and Analysis Database will be deleted.  

Note: BI4Dynamics Instance folders and the log file are not removed during the delete process.  

Uninstalling BI4Dynamics 

1. Click Start > Settings > Control Panel. 

2. Click Add or Remove Programs. 

3. From the list of installed programs, select BI4Dynamics. 

4. Click Remove. 

5. Follow the instructions on screen. 

IMPORTANT! User files will not be removed when uninstalling the solution. 
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6. Connecting Excel and Power BI reports 

6.1. Downloading Excel and PowerBI reports 

1. Open Instance 

2. Go to Install tab 

3. Click Download reports 

4. Select the destination 

5. Standard reports will be downloaded that are included with BI4Dynamics 

 

6.2. Connecting Excel reports  

6.2.1. Changing connection 

1. Open Excel report 

2. Click Data > Connections > Properties >Definition 

3. Type the database name to the Initial Catalog property of 

the Connection string. Type the Server name to the Data 

Source property of the Connection string. 

6.2.2. Creating a new connection 

4. Open Microsoft Excel 

5. Click Data > Get External Data > From other Data Source > From Analysis Services. 

 

6. Insert a Server name      

 
Do not enter “.” for local server as this connection will not work on another PC. 

If you have installed analytics on Azure Analysis Services or Power BI workspace, paste the in the 

field Server name. 

If analytical database is installed in Azure or Power BI workspace use connection link instead of Server 

name. Examples: 

Azure Analysis Services: asazure://westeurope.asazure.windows.net/bi4dynamicshybrid 
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Power BI Premium: powerbi://api. powerbi.com/v1.0/myorg/BI4Dynamics%20PPU% 

7. Click Next and select Analysis database from the dropdown menu and select Model 

8. Click Finish and OK on next form. 

You have successfully connected Excel to Analysis Services model. 

9. Start exploring your data by dragging and dropping dimensions and measures in pivot table 
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6.3. Connecting Power BI reports 

6.3.1. Changing connection 

1. Open Power BI report 

2. Click Edit Queries > Data source settings 

 

3. Type the Server name to the Server field. Type the Database name to the Database field 

 

 

6.3.2. Creating a new connection 

4. Open Power BI Desktop 

5. Click Get data 

6. Choose Analysis Services 

7. Type the Server name and Database name 

8. Choose Connect live 

 

 

If analytical database is installed in Azure or Power BI workspace use connection link instead of Server 

name. Examples: 

Azure Analysis Services: asazure://westeurope.asazure.windows.net/bi4dynamicshybrid 

Power BI Premium: powerbi://api. powerbi.com/v1.0/myorg/BI4Dynamics%20PPU% 

9. Click OK and start exploring your data 

You should see this screen: 

 
 

You have successfully connected Power BI to Analysis Services model. 


